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Input Using GIMP
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Outline

• Introduction
• Techniques for producing foreground 

mask
• Techniques for producing background 

image
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IntroductionIntroduction

• You have learnt how to use 
glTIP to create animation.

• You need to prepare the 
input image, as well as its 
foreground mask and 
background images.

Foreground 
mask  

Background 
image  
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Objectives

• In the following slides, we will discuss how 
the foreground mask and background 
image can be made using image 
manipulation software.

• We will demonstrate how to use different 
techniques to process different types of 
images

• In this workshop, the software used is 
GIMP (version 1.2)
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Why GIMP ?

• It is an open source freeware.
– Downloadable at http://www.gimp.org
– The most updated version is 2.0 (with more features)

• GIMP is as powerful as those commonly used 
image processing applications.
– It consumes fewer internal memory.
– The operations are similar. If you get used to GIMP, you 

will probably learn how to use Photoshop© easily.
• There are plenty of resources for GIMP

– Online tutorial
– libraries
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Using GIMP 1.2.3

• To open the GIMP 
program, 
– click “Start” at the 

Menu Bar -> select 
“All Programs” -> 
“GIMP” -> “GIMP”

• You may click on 
the GIMP icon 
instead
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Starting GIMP

• If you use GIMP for 
the first time, a 
setup  window will 
pop up

• You can simply 
keep pressing the 
“Continue” button 
to move on.
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Starting GIMP

• Several windows will be pop up.

Main
Window

Tool
Options Brush 

Selection

Layer, Channels & Paths



9
Workshop for ESC Honour Students July 22-24, 2005

Main Window & 
Tool Options

• Main window
– Open / close the image to 

be edited
– Choose the tools (operations 

to be performed)
– Show the color of the 

background and the brush’s 
style and color.

• Tool options
– Adjust the parameters for 

the tools selected.
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Brush Option & Layer

• Brush Option
– Allows you to select the 

style of the brush.

• Layer
– Allow you to view the 

status of the image you 
are working on (details 
will not be discussed)
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Opening a file

• To open an image, click “File”
at the toolbar -> choose 
“open”. 

• A “Load image” window will 
appear. 

• While you are selecting the file, 
you can click on the “preview”
button to check if the file is the 
correct one.

• Exercise: Open the image 
“20_d2.jpg” at the 
“note20_example” folder
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Opening a file (Cont’d)

• After you have opened the image, a 
new window showing the image will 
appear.

• The image is ready for editing.
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Resize the image

• Normally speaking, the 
dimension of the photos taken 
from digital camera is too 
large for glTIP’s input to run 
smoothly.

• You are suggested to reduce 
the image’s size.

• Right click the image 
-> select “Image” -> “Scale 
Image …”
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Resize the image (Cont’d)

• Modify the ratio or the 
dimension of the longer side (e.g. 
New Width or Ratio X) so that 
the new dimension is around 
1000 px (pixels).

• The shorter side (New Height or 
Ratio Y) will be scaled with the 
same ratio.

• Press “OK” to confirm.
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Save the image

• Right Click the image -> 
Select “File” -> “Save” to 
save the image.

• In the slides remained, 
techniques for making 
foreground mask and 
background image will 
be discussed.
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Outline

• Introduction
• Techniques for making foreground mask

– Principle
– Straight forward approach: Using eraser & 

hard edge.
– Complete the foreground mask.
– Alternative method 1: Use hand drawn region.
– Alternative method 2: Use “Intelligent scissor”

• Techniques for making background image
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Creating the foreground mask

• Principle:

– (Manually) identify the 
objects first.

– The Objects should be 
filled with white color.

– One white region 
represents one object.

– Fill the regions remained 
with black color.

1

2 3
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TIPS for making the 
foreground mask

– If two objects are 
overlapped, you should 
try to de-attach them. 

– Otherwise, they will be 
considered as 1 merged 
object.

– The 3D visual effect of 
the output animation 
will be degraded.

1

2 3
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TIPS for making the 
foreground mask

• In fact, the “foot” of the objects will 
be used to determine their distances 
from the viewpoint.

• If an object’s “foot” is located at 
lower position, it implies that the 
object stands closer to the viewpoint.

• So, you may consider to merge two 
overlapped objects as one if they are 
close enough (in 3D space)

• It will save your processing time 
without scarifying too much output 
quality. 
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A straight forward method to
produce the foreground mask

Click on the eraser button

• Left click on the image window
• Move the cursor to the 1st object
• Replace the color of the object’s 

boundary by left click and drag
the mouse around the object’s  
boundary. 

• Fill the interior part of the 
object with similar method.

Select a smaller brush (solid) 
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Example
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Remarks

• You don’t need to 
complete the step at one 
time

• Release the button and 
continue if needed.

• Press <Ctrl> with “z”
buttons to undo one step 
if you are not happy with 
the result or you have 
made mistakes.

Oops!

Press < Ctrl > + Z
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Suggestions:

• Work on the zoomed 
image to obtain a more 
accurate result

• Right Click on the image 
area -> select “View” -> 
select “Zoom” -> select 
“2:1”

• Left click and drag the 
bottom right corner of the 
image window so that you 
can view a larger area.
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Bound the objects

• Select the “Paint hard 
edge pixel” at the main 
window.

• Bound the exterior part 
of each object with 
black color

• Check carefully if the 
objects have “holes”



25
Workshop for ESC Honour Students July 22-24, 2005

Save point

• Save the image to 
another filename after 
all the objects are 
marked.

• This intermediate 
result can be used for 
making the 
background image.
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Retouch the objects

• You may not completely filled the interior part of the object.
• To avoid this, you can …

– Select “Select contiguous regions” at the main window.
– Hold the Shift button
– Click on all objects with left mouse button, then all the 

objects identified will be selected.
– Release the Shift button and right click the mouse.
– Choose “Select” -> “Feather”
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Retouch the objects & complete
the foreground mask

Right Click -> Select “Edit”
-> Fill with BG color

Right Click -> Select 
“Select” -> Invert

Right Click -> Select “Edit”
-> Fill with FG color

Done 28
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Save point

• To save the 
foreground mask
– Right Click the mouse 

button on the image 
area.

– Select “File” -> “Save 
as …”.

– Choose the proper 
directory and enter the 
file name (for example: 
20_d2_fg.jpg)
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Alternative method to mark the object
(1) - Use the “Hand Drawn Region Tool”

Select “Hand Drawn Region” Select a smaller brush (solid)

Bound the object Right Click -> Select Edit
-> Select “Stroke” 30
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Alternative method 1 (cont’d)

Right Click -> Select Edit 
-> Select “Fill with BG”

Done
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Alternative method to mark the object (2) 
– Use the “Intelligent scissor”

Suppose we want to mark the lamp pole as an object 32
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Alternative method 2 (cont’d)

• Goal: Construct a closed 
area to bound the object 
by introducing control 
points.

• Select “Select shapes
from image”.

• Left click on any place of 
the object’s boundary as 
the starting point.

Click
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Alternative method 2 (cont’d)

• Insert other control points by left-
clicking at the object’s boundary.

• The program will trace the shape of the 
object for you based on color similarity.

• Selected points will then be connected 
with grey solid lines. 

• More accurate result can be obtained by 
adding more control points, especially 
at the curved regions of the object.
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Alternative method 2 (cont’d)

• Use similar method 
to add control 
points to the pole.

• Finally, close the 
object’s boundary 
by clicking on the 
first control point.
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Alternative method 2 (cont’d)

• To select the object, 
click its interior part.

• The grey solid lines 
will be changed to 
dashed line. The 
object is now ready 
for editing.

Click
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Alternative method 2 (cont’d)

• To mark the region, you 
need to switch back to 
“Select rectangular 
regions” mode first.

• Right Click the object -> 
Select “Edit” -> Select 
“Stroke” to bound the 
object with black color.
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Alternative method 2 (cont’d)

• Finally, you can color the object in white by …
• Right Click -> Select “Edit” -> Select “Fill with BG 

color”.
• Then, you can use the “intelligent scissor” again to 

process the next foreground object.
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Trouble Shooting for 
alternative method 2

• Unfortunately, you 
cannot undo a step 
(using Ctrl –Z) if you 
have made mistakes in 
marking the object.

• You need to switch back 
to “Select rectangular 
regions” mode and select 
the “intelligent scissor”
again to start over.
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Outline

• Introduction
• Techniques for making foreground mask
• Techniques for making background image

– Principle
– Example: recover the background with regular 

patterns
– Example: recover the background with irregular 

patterns
– Another example (combined skills)
– Retouch the background and extra effects.
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Creating the
background image

• Principle:
– “Recover” the color of the 

background regions which were 
blocked by the foreground objects 
(we call it “holes”).

– Replace the color of the “holes”
with the nearby colors / textures.

– The processed background should 
gives a “natural” perception.
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Creating the background
image of a real scene

• You can fix the camera position / angle with a 
tripod.

• Take the first photo as the background image.
• Place the moveable objects inside the scene.
• Take another photo as the original image for 

glTIP’s input.
• The work for making the background image is 

minimized as you only need to create the 
foreground mask using GIMP.

• Otherwise, it is a tedious task to produce a 
background image of a real scene, although it is 
feasible.
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Creating the
background image

• This process is time-consuming but it significantly affects 
the quality of the output animation.

• However, the process could be fun as you further 
manipulate the background image so that special effects 
can be added into the animation.

43
Workshop for ESC Honour Students July 22-24, 2005

Example: Recover the background
with regular patterns

• Suppose parts of the 
background were blocked by 
the foreground objects (see 
red boxes).

• Recover the missed part 
using the visible part (see 
green boxes).

• Select “Select rectangular 
regions” so that a 
rectangular area can be 
selected. 
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Examples

• Drag a rectangle (see green box)
• Press “Ctrl” & “C” buttons to copy 

the region
• Press “Ctrl” & “V” buttons to 

paste the region into the image
• Hold the mouse’s left button and 

drag the pasted region to the red 
area.

• Left click on other part of the 
image can confirm the operation.

• You can repeat this process so 
that larger area can be processed.

1. Drag

2. Press Ctrl + C
3. Press Ctrl + V

4. Drag to the   
foreground 
object region
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Remarks

• This method works well to 
recover the background’s 
architectures or the 
background with regular 
pattern (e.g. straight lines).

• However, if the “holes”
contains irregular (or random) 
patterns, this method usually 
cannot give natural results.

• Counter example is shown at 
the right.
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Example: Recover the background
with irregular patterns

• Use the “Select hand 
drawn regions” to 
select a nearby texture 
with random shape.  

• Copy the region and 
paste it to the hole.

• Repeat this process 
until the holes are filled.  
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Examples

Before After
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Tips

• Again, you can undo one 
step by pressing “Ctrl”
with “Z” button when the 
result is not satisfactory.

• Note: Be aware of the 
changes in the light 
intensity of the scene.

• Choose the texture 
carefully so that the 
transition from a brighter 
area to a darker area is 
handled smoothly.

BrighterDarker
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Save point

• To save the Background 
image
– Right Click the mouse button
– Select “File” -> “Save as …”
– Choose the proper directory 

and enter the file name (for 
example: 20_d2_bg.jpg)

• Now, the foreground mask 
and background image can be 
inputted to generate 3D 
animation using glTIP.
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Another Example

Use “Select Rectangular 
Regions” to copy & 
paste several times
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Works similarly for 
the lower part of 
the building

Use “Intelligent Scissor”
to copy & paste a 
triangular shape with 
similar brightness

Another Example (cont’d)
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Another Example (cont’d)

Use the “Select  
hand drawn 
regions”
to fill up the 
“holes” of the sky 
and the ground.

Comment: 

Using “Select hand 
drawn region” is 
faster “Intelligent 
Scissor”
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Retouching the
background image

• You can consider to 
soften (blur) the 
background image 
so that the 
processed result 
looks smoother.

• To do so, right click 
the image -> select 
“Filters” -> Blur -> 
“Gaussian Blur”
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Processed Result

Before After
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Extra tools – Clone brush

• This tools can copy the 
texture from one position 
to another position in a 
more flexible way.

• Click on the “Paint using 
patterns or image regions”
button at the main window.

• Choose a larger brush so 
that the tool can process a 
larger area
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More settings

• You may even create a larger brush by pressing the “New”
button.

• A “Brush Editor” window will appear. Increase the brush’s size 
(~30) by moving the “Radius” slider to the right.

• Increase the Hardness (~0.8) as well.
• To prepare for the clone operations, adjust the parameters of 

the tool by choosing “Image Source” and “Aligned” as the 
source option in the “Tool Options” window.
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Clone operations

• Now, let try to recover the 
lower part of the background 
image using clone brush

• Hold the “Ctrl” button and left 
click on the image to select 
the source (red solid ring).

• Release the “Ctrl” button. 
• Left click on another area of 

the image as the destination 
(orange dashed ring), the 
content within the dashed 
ring will be replaced by the 
source.
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Example
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Remarks

• Once the start point is 
selected, the clone’s 
source will be chosen 
according to the direction 
between the first source 
point and first destination 
point.

• To change the clone 
direction, select a new 
source point again with 
“Ctrl” + left click operation.
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Effects of Clone Brush

1. Hold Ctrl + click

2. Drag along this 
direction
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Effects of Clone Brush

Go downward and sweep 
along similar direction

Work similarly for the right
hand side but work on 
smaller distance to give 
finer tunes.
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Smoothing the
transitional area

• Reduce the opacity of the 
clone brush (~35)

• Select a point near the 
boundary between the 
bright and dark region as 
the source

• Dark region is used as 
starting point in this 
example

• Do the clone operation 
from the dark region to 
bright region
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Smoothing the
transitional area (Cont’d)

• Do the clone operation in 
reverse direction if 
necessary until a 
satisfactory outcome is 
achieved.

• Again, you can press “Ctrl”
with “Z” to undo one step 
if needed.

• Note: Save different 
intermediate results into 
different file so that you 
don’t need to redo 
everything if big problems 
occur.
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Protect the original 
background

• Even more, you can use the 
“Select contiguous regions” to 
pick the foreground mask area.

• Then, the clone effect will apply 
on the selected areas only; the 
background will not be modified.

• This is important if the clone 
operation is performed at the 
area containing image detail. 
(e.g. the mountain)
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Clone effect on the foreground
mask regions only
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Enhance the image

• If a photo is too dark to 
locate the foreground 
objects, (especially when it 
is taken during nighttime), 
you may also adjust the 
brightness and contrast.

• It is easier to produce the 
foreground mask and the 
background image if the 
photo has better contrast.
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Brightness / Contrast 
adjustment

• Right click the image -> 
Select “Image” -> “Colors” -> 
“Brightness-Contrast …”

• Increase the Brightness (of 
the entire image) and 
Contrast (between the bright 
regions and dark regions) 
using the sliders.

• Press “OK” to confirm the 
changes.
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Extra Effects ?

• There are various filter functions 
(right click -> select “Filters”)  that 
could make your image more 
interesting.

• Try to play around with them and 
see if they are useful.
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Examples

Colorify

Channel Mixer

FlaresFX

Emboss + Motion Blur
70
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Q & A Session


